Type | Notes |
---|---|
AIX | oem_setup_env VIOS AIX shell |
AIX | smtctl – multithreading, emstat -v – emulated cpu instructions, vmstat -v (tail -5 for buffers issues) performance stats, lvmo -a lvm tunables, svmon -P pid, ioo -FL (compares tunabled values, defaults and current), vmo -F -a (shows all, including restricted tunables) |
AIX | filemon -o <outputfile> to outfile, use -O detailed,all for all levels, -d requires trcon to start. i.e. filemon -d -T 5242880 -O detailed,all -o fmon.out |
AIX | lsattr -E -l sys0 -a maxuproc, Maximum processors per user |
AIX | trcstop to stop filemon |
SP | Commands to multiple TSM Servers TSM1,TSM3: <command> |
AIX | mksysb example “/usr/bin/mksysb -i -X /opt/redback/uda1-pcc-dcp.mksysb.08022011” |
AIX | date +%m = Decimal month, date +%M =Decimal minute, date +%h = character month, date +%H = decimal hour, date +%d = decimal day, date +%D = date |
UNIX | simple loop example, while sleep 5 </n>, do </n>, lspath </n>, done |
SP | TSM server 6.n startup . /home/tsminst2/sqllib/db2profile, cd /home/tsminst2/, /opt/tivoli/tsm/server/bin/dsmserv -q -u tsminst2 -i /home/tsminst2 & (For TSM1 use user “tsm1”) |
SP | TDP validation “/usr/tivoli/tsm/tdp_r3/ora64/backint -p /oracle/QEC/102_64/dbs/initQEC.utl -f password” |
SP | TSM exceptions “q event * * exc=yes” |
AIX | oslevel -r -g 6100-07, to list filesets greater than 6100-07. oslevel -r -l 6100-07 to list filesets less than 6100-07 |
UNIX | (set user id) and sgid (set group id) are the equivalent of adopted authority in i5OS. Are represented as an “s” in the executable part. e.g. chmod u+s |
UNIX | When a directory has the sgid mode enabled, any files or directories created in it will inherit the group id of the directory. |
UNIX | Sticky bit is displayed in a long directory listing in the place of the executable flag as “t” for other users (the last character), with the same meaning for upper and lower case as for suid and sgid. If set for a directory, it permits only the owning user or the superuser (root) to delete or unlink a file. |
UNIX | nmon -f -s 30 -c 2880 -m /backupdb |
AIX | mount -v cdrfs -o ro /dev/cd0 /mnt |
AIX | User last login, lsuser <username>, /etc/security/lastlog, last -1 <username>, |
AIX | Reset user, chsec -f /etc/security/lastlog -a unsuccessful_login_count=0 -s <username>, chuser “account_locked=false” <username> |
AIX | chroot aix, /etc/ftpaccess.ctl and puseronly:test123 (below) readwrite:/home/test123, restart ftp subservers stopsrc -t ‘ftp’ and startsrc -t ‘ftp’ . GUI to work /usr/samples/tcpip/anon.users.ftp <username> |
SP | “tdpsqlc query tsm *” query all backup objects |
AIX | if 0042-027 NIM machine has no “Mstate” attribute, run a check NIM client operation first and that will create a Mstate value. Then you can reset and deallocate NIM resources from the NIM client machine. |
SP | TSM “show version” command to examine objects and their states. |
AIX | “cat filename | chpassword” , for batch password changes. File format is username:password |
AIX | /etc/security/lastlog is last login. /etc/security/failedlogin, who /etc/security/failedlogin and /usr/sbin/acct/fwtmp < /etc/security/failedlogin, to read failed logins. |
UNIX | NFS /etc/exports, /etc/xtab, exportfs -v, showmount -e |
SP | TSM unix restore example dsmc restore /export/spot/uda1-pcc-dcp-spot/usr/”*” |
AIX | lsnim -a spot , whill give you a list of allocated spot resources |
AIX | lppchk -v (lpp verification) |
AIX | HISTFILE varaible controls history, .sh_history in home directory if variable isn’t set. |
AIX | To fix mismatch filesystems, varyoffvg, exportvg and importvg or try redefinevg -d hdiskn vgname and synclvodm |
AIX | lqueryvg -p hdisk0 -v to associate a disk with a volume group id |
AIX | smitty mpiopath – manage AIX multipath IO |
UNIX | set -x # activate debugging from here and +x to stop debugging and ksh -x debug at runtime |
STG | SVC CLI – see history “svcinfo catauditlog -delim : -first 15” |
AIX | lspv | awk ‘{system(“bootinfo -s” $1)}’ command from awk (space maybe needed in the command) |
AIX | lsuser -ca unsuccessful_login_count ALL | awk -F”:” ‘{print $2}’ Awk delimeter |
AIX | cat /etc/security/lastlog | grep -e :$ | grep -v ^* | tr -d “:” | awk ‘{system(“lsuser -a unsuccessful_login_count “$1)}’ | tr -s “=” ” ” | awk ‘{if($3 > 2) system(“chsec -f /etc/security/lastlog -a unsuccessful_login_count=0 -s ” $1)}’ Awk with tr |
AIX | “lsdev -p fscsi1” List child devices |
AIX | “mkfs -V jfs2 /dev/lvname” format a logical volume for reuse |
AIX | startsrc -s sendmail -a “-bd -q30m” Send mail start if stuck |
DB | Oracle connectivity export ORACLE_SID, sqlplus / as sysdba. Tna and listerner config files are in $ORACLE_HOME/network/admin |
DB | Oracle recovery ,startup mount; RECOVER DATABASE UNTIL CANCEL USING BACKUP CONTROLFILE; (Specify second most recent redo log fullpath) ALTER DATABASE OPEN RESETLOGS; |
DB | Oracle commands select name from v$datafile; (Database Files) select group#, member from v$logfile; (redo logs) |
UNIX | if [ ${STATUS} != ‘prepared’ ] example using != for characters |
UNIX | ssh-keygen -t rsa, to generate rsa key pair |
SP | Windows command line TSM restore. Use drive letters, instead of UNC filespace names |
SP | TDP SQL restore from differential. First restore FULL with log without Recovery option and replace checked. Then restored the difffull with the log and without replace and with recovery checked. |
AIX | Add VLAN’s to SEA, create new Virtual IO adapter (l-lan) on VIO servers. chdev -dev entX -attr virt_adapters=entY,entZ (where entX is the SEA and entY is the adapter that was already part of the SEA and entZ is the new virtual adapter) |
UNIX | ksh hints use “?” For a single level wildcard for ls. Use “/” to search for previous entry in vi mode. |
SP | TSM Client version SQL select node_name from NODES where CLIENT_VERSION=’6′ and CLIENT_RELEASE=’1′ and CLIENT_LEVEL=’3′ |
IBMi | MIMIX v6 FILE exclusions, Make sure COOPDB is *NO and TYPE is FILE and OBJATR is ‘PF-DTA’. Then LODDGFE will ignore excluded files correctly. |
AIX | pwdadm -c user This will remove the ADMCHG flag without need to vi the file directly. |
AIX | Performance HMC wide, lparstat, app displays the the availble CPU’s in the shared processor pool. Need “Allow performance information collection” checked in the LPAR profile to see app. |
AIX | Additional processor pools can be capped by the maximum CPU setting and CPU’s can be reserved (but not allocated to a particular LPAR) for uncapped CPU pool ultilization. The maximum setting must include allocated CPU and the reserved CPU. |
AIX | OS processor folding, 5.3 onwards can consolidate threads to use less VCPU’s. Processor folding can be disabled: #schedo –o vpm_xvcpus=-1 |
AIX | chvg -t 2 vgname, to change a VG to factor 2 (This means that the PP size per PV doubles, but the MAX PV’s decreases by half) |
AIX | export TERM=vt100 to have the more command output stay on the screen. |
SP | dsmc incr /fs (filesystem without trailing slash will update incremental information) |
SP | dsmc incr -subdir=yes /fs/dir/ (directory will not update incremental information and will re backup data) |
STG | svcinfo and svctask -? List all commands SVC CLI |
LIN | date -s “MM/DD/YYYY hh:mm” set time and hwclock –systohc hardware clock sync |
UNIX | Redirect stderr output to a file “command 2> outfile.txt” |
UNIX | cp -pR is best for recursive copy |
AIX | DLPAR remove device, do not delete device from configuration profile first. Have to changed to desired or not required in configuration profile first and then DLPAR will work. Then delete from configuration profile. |
SP | TDPSQLC with MSSQL native authentication /SQLAUTHentication=SQLUserid /SQLUser=sa /SQLPassword=password |
AIX | HMC Wizard http://www-912.ibm.com/s_dir/slkbase.NSF/1444e529a72ba96486256a6400681992/c69799b70a28578c8625712c004fe06b?OpenDocument |
AIX | HMC and firmware matrix, http://www-933.ibm.com/support/fixcentral/firmware/supportedCombinations |
AIX | lsdev -dev ent5 -attr , VIO lsattr equivalent |
AIX | /usr/lpp/Atape/instAtape -a ,will unconfigure all devices that have alternate pathing set to No,and will reconfigure all devices, setting alternate pathing to Yes. |
AIX | entstat: 0909-003 Unable to connect to device ent4, errno = 19, means that SEA has failed over to other VIO |
AIX | NIM SPOT checks, nim -o check aix61tl3sp3_spot and nim -o lppchk -a show_progress=yes aix61tl3sp3_spot |
AIX | NFS stopping state, startsrc -s portmap |
AIX | move logical volume to another volume group, create new log volume and format “logform /dev/loglv04”, change filesystem attributes pointing to new lv and log lv “chfs -a dev=/dev/poolsqlmetalv -a log=/dev/loglv04 /poolsqlmeta” and then “fsck -p <newlv>” |
AIX | smit install_latest, Install latest software |
UNIX | ldd to see dynamically linked objects required for binaries |
AIX | NPIV commands, “lsmap -npiv -all” to list vfchosts (which are created by a Virtual Fiber Client server mapping in the HMC). vfcmap -vadapter vfchostn -fcp fcsn (mapping the virtual NPIV adapter to a physical HBA port). Create the Client Virtual adapter first, Using the first WWPN. |
AIX | “redefinevg -d hdiskn rootvg” to sync PV information to the ODM |
AIX | “lqueryvg -Atp hdiskn” shows VGDA information on physical volumes |
AIX | splitvg will create a new snapshot vg from a mirrored vg, joinvg will recreate the mirror. |
AIX | recreatevg will create a vg from a hdisk |
AIX | rendev -l ent0 -n ent99, rename devices (AIX 6.1 and 7.1) |
AIX | ipl_varyon -i, shows all disks with a boot signature |
SP | TSM Export commands, QUERY EXPORT, SUSPEND EXPORT, CANCEL EXPORT, RESTART EXPORT |
AIX | fslvname usually indicates a logical volume that is part of a snapshot vg |
SP | dsmadmc -commadelimited, for comma delimted output |
AIX | bootlist -m normal -o, display bootlist |
DB | bin/uv -admin -stop Universe stop .uvhome will show environment |
AIX | chfs -a mount=true /filesystem |
UNIX | If a filesystem is locked, try fuser -u /dev/lvname |
AIX | ifconfig -ld down IP interfaces, ifconfig -lu up IP interfaces |
AIX | errlog is VIO version of errpt |
AIX | Changing VIO SEA priority, chdev -dev entn -attr ha_mode=standby to make backup. chdev -dev entn -attr ha_mode=auto to set back to revert to primary or auto failover status |
AIX | change paging space, chps -s nn hd6 (add PP’s), chps -d nn hd6 (substract PP’s), lsps -a (Detailed list of paging space and logical volumes) |
AIX | when copying /etc/users and groups, must recreate user and group pconsole. Experienced issue when installing new TL level on AIX 6.1 |
AIX | For X11 forwarding to work on AIX, X11 filesets must be installed, including x11.dt and xauth which is included in X11 config fileset (AIX 6.1) |
AIX | lsattr -Rl devicename -a attributename will list all viable attribute settings. |
AIX | chdev -l ‘smc1′ -a alt_pathing=’yes’, MPIO tape library. Control path. |
SP | append waitt=0 against checkin libv TSM commands to negate tape load request. |
AIX | diag, Task selection, used for tape scsi resets. |
AIX | chpath -l hdisk1 -p scsi0 -s disable, chpath example |
UNIX | find +mtime and +ctime modified time and creation time. |
AIX | rpcinfo -p for RPC info and nfso -a for NFS tunables. NFS v3 is TCP, and NFS v2 is UDP. |
AIX | netstat -i for MTU |
AIX | smit nim_mac_op, Perform NIM client tasks from NIM server. |
SP | dsmc restore /tempspace2/SE/ -subdir=yes, Complete TSM restore |
AIX | nim -o showres lpp_source1, Show contents of a NIM resource. |
AIX | nim -o update -a packages=all -a source=/dev/cd0 lpp_source1, update NIM resource |
AIX | nim -o update -a packages=”bos.games 5.2.0.0 bos.terminfo” -a source=/dev/cd0 lpp_source1, Single fileset update |
AIX | nim -o update -a recover=yes -a source=/dev/cd0 lpp_source1, recover missing SIMAGES from OS installed CD |
AIX | /usr/lib/instl/lppmgr -d /export/lpp_source/directory -uxV, check for superseded and duplicate filesets |
AIX | lsnim simages(“support images”) lpp_source flag denotes that it is OS installable |
AIX | nim -o allocate -a lpp_source=LPPRESOURCE_NAME MACHINE, Allocate nim resource example to a machine |
AIX | lsnim -O MACHINE will list valid operations |
AIX | nim -o check NIMRESOURCE, Check NIM resource |
AIX | lslpp -w /usr/sbin/binaryname, shows what fileset is attached to the binary |
AIX | lslpp -d, dependent filesets |
AIX | lppchk -v -m 3, shows detailed information about required filesets |
AIX | nim -o showlog -a full_log=yes -a log_type=nimerr ULT4-TAS-DCP, NIM error log for a particular NIM object |
AIX | smit lsmksysb, list contents of mksysb. restore -T will also do this |
AIX | smit lsbackvg, list contents of savevg |
AIX | smit restmksysb, restore mksysb files |
AIX | smit restsavevg, restore savevg files |
AIX | loopmount -i /spare/Image_110710_1447.iso -o “-V cdrfs -o ro” -m /mnt, mount an iso image |
AIX | chpv -h y hdisk3, to create hotspare disk in volume group. |
AIX | smit nim_mac_op,select “cust” and specify fileset(s), to install filesets to a machine. Must allocate an lpp_source resource first. |
AIX | After mksysb restore, smit chgsys and change the maximum number of processes per user 4096 |
AIX | After “Restorevg” underlying mount point permissions are not properly retained. |
SP | “restart restore” will restart a restartable TSM restore session from the BA client |
AIX | “lsmcode -d <device>” display microcode |
DP | syscat.tables and syscat.columns for TSM SQL |
SP | pwdadm -f NOCHECK <username>, circumvent password restrictions in /etc/security/user |
PC | Excel YMD to DMY, format number fields to custom yymmdd and then use the “Data” Text to Columns tool to convert. |
AIX | redefinevg -d hdisk0 rootvg, re-associate a physical volume to volume group. Then synclvodm -v old_rootvg, to rebuild the logical volumes. This was done after varyonvg had failed. |
AIX | chpv -Cc <hdiskn>, the disk no longer has an old vgda or boot image |
AIX | readvgda <hdiskn>, physical volume data area information |
AIX | lspv -free , unmapped VIOS disks |
AIX | sysdumpdev -l, system dump information |
AIX | enq -AWs, list of AIX printers |
IBMi | WRKTIMZON, i5OS time zone detail |
UNIX | who -r, runlevel AIX |
AIX | /var/adm/cron/log, cron logs |
AIX | multibos, same OS level. -s setup, -S shell |
AIX | lslpp -S O optional filesets and lslpp -S A lists filesets with installation. |
IBMi | CPF2469 unmonitored by QSRSLCP2, to resolve BRMS issue clear the SAVACTMSGQ message queue. |
COBOL | mflicense, cd /opt/microfocus/mflmf, lmfgetpv (Info), mflm_cmd (input licence) use “/ number” as function keys |
AIX | lshwres -r virtualio –rsubtype fc –level lpar -m <managed frame>, List all virtual IO for a managed system. |
AIX | telinit q to examine the /etc/inittab |
AIX | vtmenu, from HMC for console from hmc shell. mkvterm -m <managed frame> -p <lpar name>. To close console rmvterm -m <managed frame> -p <lpar name> |
IBMi | CHGSRVA PTFGRPLVL(0001), V6R1 single PTF view |
LIN | dmidecode, linux hardware information |
IBMi | WRKRDBDIRE, *ALWLOWER apprears just to require *USRID (User ID only) |
SP | select sum(backup_mb)+ sum(archive_mb)+ sum(spacemg_mb) as PRIMARY_MB from auditocc, total occupancy for TSM servers |
VXFS | vxdisk rm <diskname>, remove veritas disk |
VXFS | vxdg destroy <dgname>, remove disk group |
VXFS | vxdg -T 140 init <testdg> <devicename>, add disk to diskgroup using vxvm 5.0 compatible private region. |
VXFS | vxassist -g <diskgroup> make <logicalvolume> 2000m, create 2G volume |
VXFS | vxvol -g <diskgroup> start <logicalvolume>, start logical volume (after import) |
AIX | chlv -n <newlvname> <lvname> , rename logical volume. |
SLR | zoneadm list -cv, list solaris zones |
SLR | zlogin zone, login into zone from global zone. |
SP | del group {VMFULL}\TSM\VMFULL\* -ina -pick, select FULLVM VCB backups to delete |
AIX | /usr/bin/ioscli -> /usr/ios/cli/ioscli, use VIOS commands in oem_setup_env |
UNIX | rpm -qpR gnupg-1.4.11-2.aix5.1.ppc.rpm, see rpm dependencies before install |
SLR | devfsadm, scan for new Solaris devices |
UNIX | Unix file owners, can change permissions of file. |
AIX | lvmstat -v datavg -e, start lvmstat volume group collection. Replace the -l for logical volume |
AIX | lvmstat -v datavg -d, stop lvmstat volume group collection Replace the -l for logical volume |
AIX | lvmstat -v datavg -c 5, list top 5 logical volumes in the volume group |
AIX | AIX checksum on a file, cksum. |
AIX | change “sa” in /etc/bootptab to NIM server alternate IP and refresh -s inetd, after nim resource allocation and before bos install via NIM. (depreciated process) |
AIX | Create a new entry in /etc/hosts, Have to define new interfaces for VLAN IP address via Manage Machines -> Manage Network Install Interfaces -> master -> select “VLAN IP hostname” |
AIX | lsnim -l master, shows interfaces and other nim information |
AIX | crfs -v jfs2 -g'<vgname>’ -a size=’78G’ -m’/filesystem’ -A’yes’ -p’rw’, easy way to create a jfs2 filesystem |
VXFS | /usr/lib/vxvm/bin/vxdiskunsetup, to remove disk from vxvm |
SLR | uadmin 2 0, go to Solaris domain console OK prompt |
SLR | zfs get all <zpoolname> |
VXFS | vxdisksetup -i <diskname> format=cdsdisk, add disk to vxvm control |
VXFS | vxdisk scandisks, scan for new vxvm disks |
VXFS | mkfs -F vxfs /dev/vx/rdsk/<diskgroup>/<volume> |
VXFS | vxdisk -g <diskgroup>-f resize <disk> |
VXFS | vxresize -g <diskroup> -F vxfs <volume> +10g, resize filesystem |
IBMi | SNDSRVRQS *TEST, send IBM service test |
AIX | /usr/sbin/rsct/install/bin/uncfgct, unconfigure ctrmc resource manager (DLPAR) |
AIX | /usr/sbin/rsct/install/bin/cfgct, configure ctrmc resource manager (DLPAR) |
AIX | rmcctrl -z, resets ctrmc resource manager (DLPAR) |
AIX | rmcctrl -A, resets ctrmc resource manager (DLPAR) |
AIX | lspartition -dlpar, currently DLPAR capable LPARs |
AIX | lssyscfg -r lpar -m 9406-570-SN651F45C -F name,rmc_ipaddr, IP addresses of DLPAR systems |
UNIX | du -a /var | sort -n -r | head -n 20, top 10 files sorted |
SLR | zfs mount, list mounted zfs directories |
AIX | errclear 0, to clear AIX errpt log |
AIX | route get <IP address>, determine what AIX interface is being used for a route |
UNIX | unshare <hostname>:/directory to remove exported nfs filesystem |
UNIX | share, list nfs exported filesystems |
UNIX | ps awxl, show nice values |
AIX | export LDR_CNTRL=MAXDATA=0xD0000000@DSA, resolve AIX memory errors with 64bit to 32bit rsync transfer |
UNIX | xargs -n2 <command> Reads output from the previous command and will process the output as two arguments (seperated by spaces). |
AIX | ssh pam enablement, Usepam=Yes in sshd_config. chsec -f /etc/security/login.cfg -s usw -a auth_type=PAM_AUTH. Add sshd entries in /etc/pam.conf file for auth, account, password and session |
AIX | Change login length, chdev −l sys0 −a max_logname=18, to see new value “getconf LOGIN_NAME_MAX” |
SP | select NODE_NAME,REG_TIME from NODES where REG_TIME LIKE ‘%2011-12%’, When TSM nodes were registered. |
STG | Brocade Zone admin, Create a new alias in Alias Tab and assign a member WWPN from the left pane -> Create a new zone in the zone tab and assign members from the left pane -> In the Zone admin tab, add left pane inactive zones (black) into the right pane. -> Save and Enable config to complete |
AIX | alt_disk_copy is an AIX 5.3 replacement for alt_disk_install |
SP | UNIX |
UNIX | egrep ‘<string1>|<string2>’ , grep multiple patterns |
AIX | usrck -y <username> , run this against users after manually copying AIX /etc security files. May also have to run pwdck and grpck to reconcile any password and group issues. |
SP | MSSQL TDP restore to a different database name. In the Restore Databases tab, Check the required databases and logs, right click on the selected database backup and select “Restore Into” type a new Database name. Then right click on the selected database backup and select “relocate” and browse to a different directory. |
AIX | reboot, AIX immediate reboot |
AIX | Validate AIX installation, instfix -i |grep AIX. If a <OS_TL> level reported not all filesets were found, then instfix -ivk <OS_TL> |grep not|grep : ,will report the relevant filesets |
AIX | lssyscfg -r sys -F name,state , Server names from HMC |
AIX | lssyscfg -r prof -m <Server-Model-Serial> -F lpar_name,desired_procs,desired_proc_units,desired_mem , List HMC profile information |
AIX | lshwres -r proc -m <Server-Model-Serial> –level lpar -F lpar_name,curr_procs,curr_proc_units , List HMC LPAR processor information |
AIX | lshwres -r mem -m <Server-Model-Serial> –level lpar -F lpar_name,curr_mem , List HMC LPAR memory information |
AIX | lshmc -V , HMC information |
AIX | AIX 5.3 and before AIX 6.1 TL4. Cannot dynamically grow rootvg. |
AIX | swapon </dev/paginglv> and swapoff </dev/paginglv>, is used for activating page files in AIX |
SP | dsmc restore -fromnode=cougar \\cougar\d$\projx\* d:\projx\, restore from TSM node cougar |
AIX | TMOUT=10800, Unix shell time out ksh. |
LIN | authconfig –test, Linux RH5 to show authenication configuration |
LIN | chage -l <username>, Linux Redhat show password policy |
LIN | pam_cracklib.so, Linux password complexity module |
SP | brtools -V, shows brtools version |
SP | /usr/tivoli/tsm/tdp_r3/ora64/backint -p /oracle/DBI/102_64/dbs/initDBI.utl -f inquire, backint ID information. |
SLR | cat /etc/release, Solaris version |
SP | restore /cfptmp/ftpdirector/ /u114/ -subdir=yes -inactive, restore directory to another location. |
SLR | share -F nfs -o ro /tsmbackup, Solaris nfs share |
SLR | flarcreate -n CFPPROD -U “content_architectures=sun4u,sun4v” -c /tsmbackup/CFPPROD.flar, create flar system archive outside of the root disk. |
SP | dsmc q backup /*/filename* -inactive, search for backup files in dsmc client |
SLR | showdomainstatus –a, list Solaris domains in console |
SLR | /etc/defaultrouter, add an IP address and reboot for default Solaris route. |
SP | <INSTANCE_HOME>/sqllib/db2nodes.cfg, has to be changed to a new host name if imaging a TSM server from another system. Also db2set -g DB2SYSTEM=<newsystemname> and db2set -all to check the changes, must be signed on as TSM instance user first. |
AIX | Rename a Volume group, exportvg and then importvg using a different name |
AIX | smit nimadm, NIM alt disk migration (must be rsh capable) |
AIX | mtu_bypass, enN attribute in AIX 6 – 7 for persistent IP large send. |
AIX | chlv -e’x’ <lvname>, change a logical volumes inter disk POLICY to maximum. To distribute PP’s across as many physical volumes as possible. |
AIX | AIX ssh permission denied issue, check the /etc/pam.conf file for the ssh entries. |
AIX | lspath -l hdisk57 -F “connection parent path_status path_id status” -H, for full lspath output |
AIX | lsof -i:<port number> to determine running process on a socket |
UNIX | ps -t pts/<n> display all processes on that terminal |
UNIX | ps v shows memory and cpu stats for process |
UNIX | jobs -l shows jobs submitted in the session |
UNIX | ps -eo pid,pgid,tty,status,args to see the process group id |
DB | exp / file=/u0/app/oracle/admin/l012band/dpdump/test.dat log=/u0/app/oracle/admin/l012band/dpdump/test.log full=yes, to export oracle database to a particular file. |
UNIX | ulimit -f unlimited, ulimit -d unlimited, to remediate “cp: Requested a write of 4096 bytes, but wrote only 3584.” |
SLR | Solaris top equivalent is prstat |
AIX | VIOS NIM restore, smit nim_mkres -> Manage Control Objects -> Define a Management Object -> vios -> management source = <managed system> , Identity <LPAR ID> via lssyscfg -r lpar -m <managed server name> -F name,lpar_type,lpar_id|grep vioserver |
AIX | HMC and server call home serviceability requires that “Manager Customer Information” is populated in the HMC, especially customer number |
UNIX | ls -la | tee <filename> , to have screen output and pipe to a file simultaneously |
STG | host_list, XIV CLI list hosts WWPN |
STG | host_connectivity_list, XIV CLI host to fc port relationship |
STG | fc_port_list, XIV CLI lists the fc ports |
UNIX | script <file.out>, all screen output is copied to this file. Type exit to stop the copying of output. |
AIX | truss -fp <process id>, debug a process id. |
UNIX | find /directory -name ‘*.nmon’ -mtime +75 -exec rm -f {} \\; find command working in crontab |
IBMi | Call QSYS/QLZARCAPI, systemi CPU LPAR information |
AIX | iptrace -i <interface> -s <hostname> -b /outfile.trace, can be started and stopped by startsrc and stopsrc |
AIX | AIX perfpmr tool, http://www-01.ibm.com/support/docview.wss?uid=aixtools-42612263 |
AIX | VIOS advisor tool, http://www.ibm.com/developerworks/wikis/display/WikiPtype/VIOS+Advisor |
AIX | PCAP output from AIX, tcpdump -v -w /trc_data/outfile.log host <IP address> |
AIX | tapeutil -f /dev/<tape device> reset, 3494 tape drive reset |
AIX | tapeutil -f /dev/<tape device> status |
UNIX | nice -n 10 /<script> , adds a 10 to the default of 20 and creates the jobs with the nice value of 30, with a total priority of 70 collectively (default priority 60) |
UNIX | renice -n 10 -p 1683, adds a 10 to the default of 20 for an existing process |
AIX | lsfs -q <filesystem>, for filesystem information |
UNIX | Broadcast messages are sent via the “wall” command. |
SP | select DOMAIN_NAME,SCHEDULE_NAME,NODE_NAME from ASSOCIATIONS where NODE_NAME like ‘%<NODE>%’, to determine what nodes are associated what schedules |
AIX | List NIM objects that are locked, lsnim –a locked To unlock NIM objects, /usr/lpp/bos.sysmgt/nim/methods/m_chattr -a locked=”” <NIM object name> |
SP | validate extents <dedup pool> action=markdamaged, To validate TSM dedupe extents |
DB | ARCHIVE LOG LIST, Oracle archive mode, destination and sequence. |
DB | show parameter log_archive_dest, Oracle archive log destinations |
DB | SELECT NAME FROM V$CONTROLFILE; List oracle control files |
DB | ALTER SESSION SET NLS_DATE_FORMAT = ‘DD-MM-YY HH24:MI:SS’; Set oracle environment date format |
DB | select NAME, SEQUENCE# from v$archived_log; Oracle archive log file names and sequence number |
DB | select NAME, SEQUENCE#, THREAD#, FIRST_TIME, FIRST_CHANGE#, NEXT_TIME, NEXT_CHANGE# from v$archived_log where SEQUENCE# > <log sequence number>; shows oracle SCN numbers and oracle archive log file. |
DB | recover database until change <SCN number>; Oracle database recovery specifying an SCN number, specify AUTO when asked for a filename. |
DB | ALTER DATABASE OPEN RESETLOGS; This is to run after a oracle database recovery |
DB | alter system switch logfile; create new archive log file. |
DB | SELECT dest_name, status, destination FROM v$archive_dest; Oracle archive log destinations |
DB | alter system set log_archive_dest_1=’location=<archive log directory>’; set the archive log directory |
DB | Oracle system01 datafile recovery, recover datafile 1; alter database open |
DB | Databases that need recovery, select * from v$recover_file; select substr(name,1,50), recover, fuzzy, checkpoint_change# from v$datafile_header; |
AIX | http://www.ibm.com/developerworks/aix/library/au-migrate_nimadm , NIM admin migration process |
LIN | password requisite pam_cracklib.so try_first_pass retry=3 minlength=8 lcredit=-1 ucredit=-1 dcredit=-1 difok=1 type= , Linux /etc/pam.d/system-auth RH6 password complexity |
LIN | password sufficient pam_unix.so md5 shadow nullok try_first_pass use_authtok remember=10, /etc/pam.d/system-auth RH6 password history |
LIN | /etc/login.defs, Linux global password attributes and aging. |
AIX | NIM interface clean up, nim -o change -a if22= -a cable_type22= master |
SP | dsmc -virtualnode=<NODENAME>, connect as a another node bypassing locally configured node. |
AIX | ncheck -i <inode> <lvpath>, to find AIX inode |
AIX | fileplace -pv <filepath>, show fragmentation and placement of files |
AIX | gensyms -F > gensyms.out, trace -a -T 768000 -L 90000000 -o trace.out, filemon -i trace.out -n gensyms.out -O collated | more, filemon in offline mode |
AIX | /usr/sbin/mklv -y'<lvsnapshotname’ -t’jfs2′ <vgname> <PPnum>, snapshot -o snapfrom=<fsname> <lvsnapshotpath>, create lv snapshot |
AIX | mount -v jfs2 -o snapshot <lvsnapshotpath> <filesystem>, mount snapshot volume |
AIX | PS1=`whoami`@`hostname`’:’${PWD}’>’ , for shell prompt |
AIX | TMOUT is the variable for AIX login timeout |
AIX | topasout -a /etc/perf/daily/<topasrecfile>, to convert topasrec output into nmon readable csv file |
AIX | /usr/sbin/acct/fwtmp < /etc/security/failedlogin, to record failed logins |
UNIX | nmon -f -t -s 30 -c 120 -m /tmp, with give you process pid information. |
LIN | printf “\033]; `uname -a` \007\003\n”, Terminal screen identifier |
AIX | getconf DISK_SIZE /dev/<hdiskn>, getconf -a, AIX get configuration command |
SLR | fcinfo hba-port, Solaris fiber adapter info. |
SLR | eeprom, System serial number. |
STG | Brocade commands, nodefind, alishow, zoneshow. |
AIX | mkuser pconsole, mkgroup -‘A’ users=’pconsole’ pconsole, chuser pgrp=pconsole pconsole, mkgroup -‘A’ users=’snapp’ snapp, multibos -sX, mount <nimserver>:/<lpp source directory> /mnt, multibos -Xac -l /mnt, multibos -S, oslevel -s, Multibos upgrade |
LIN | export http_proxy=http://<IP:Port>/ , Redhat proxy setup |
AIX | svmon -G -O unit=MB, AIX global memory usage |
LIN | systool -c fc_host -v | grep “port_name”, RH WWPN ports |
AIX | lsvg <vgname>, to see remaining stale PPs in copy operation. |
SLR | zfs set aclmode=mask <filesystem>, post oracle solaris live upgrade acl fix |
AIX | AIX core debug, cd to directory of core file. lquerypv -h core 6b0 64, to the program and then dbx <full path of program> core |
UNIX | find <filesystem> -inum <number>, to resolve inode number |
AIX | truss -pfa <process id>, for full truss output |
SP | dsmadmc -tabdelimited, for tabdelimited output |
AIX | pagesize -a, AIX capable pagesizes |
AIX | kdb, memp *, to show memory pool utilization. There may be an issue with the memory_affinity tunable. |
AIX | mailq, sendmail -q -v, sendmail diagnostics |
SP | show resq, show TSM resource queue |
SP | show damaged <storage pool>, shows TSM damaged objects |
SP | show bfo <aggregates>, to help diagnose “Inconsistent content for alias aggregates” |
UNIX | ssh <command> <hostname> ‘command1;command2’, encapsulate multiple commands in single quotes. |
AIX | lshwres -r io -m <servername> –rsubtype slotchildren -F phys_loc,description,wwpn – show WWPN’s in HMC |
AIX | installp -s, to view all AIX APPLIED filesets . |
AIX | lslpp -e or emgr -l, to view all AIX interim fixes. |
AIX | chdev -dev <hdiskn> -attr max_transfer=<value> for vscsi, will only work if you change all the vios vhost adapter disks to the same value. |
AIX | installp -c all, to commit all applied filesets |
AIX | /etc/swapspaces, configuration for paging spaces and mkps to create new swapspace. |
EXCH | get-MailboxDatabase, get-StorageGroup, remove-MailboxDatabase -identity <Server\RSG\Database>, remove-StorageGroup -identity <Server\RSG>, Utilities -> Mailboxes. TDP Mailbox restore information. |
SP | q nodedata * volume=<volumename>, what node data is on a particular volume |
SP | q schedule nodes=<NODE NAME>, determine what schedules are a associated to a particular node |
AIX | installp -acY -d/<directory>/ <fileset>, Install AIX fileset from directory. |
DB | select a.member,a.group#,b.status from v$logfile a ,v$log b where a.group#=b.group# and b.status=’CURRENT’, current oracle redo log |
AIX | lsmksysb -l -f /<mksysb_file>, high level mksysb information. |
AIX | lsmksysb -L -f /<mksysb_file>, mksysb fileset information. |
AIX | nim -o lppmgr -a lppmgr_flags=”-rbux” <lpp_source>, remove duplicate filesets from nim resource |
AIX | nim -o lppmgr -a lppmgr_flags=”-lsb” <lpp_source>, list duplicate filesets from nim resource |
SP | TEMPLOGREstorepath and and TEMPDBRestorepath in tdpexc.cfg, TDP restore for RDB or RSG |
AIX | trustchk -n ALL, checks the integrity of the trusted execution database. |
SP | SHOW DEDUPDELETEINFO, shows TSM dedupelication delete information |
AIX | /etc/ibm/sysmgt/dsm/nodeinfo, is required for NIM control objects to function. |
AIX | /etc/ibm/sysmgt/dsm/nodeinfo entry, “<nim machine>|hmc|<hmcname>||TargetHWTypeModel=<type>-<model>|TargetHWSerialNum=<serialnumber>|TargetLPARID=<number>|<password file>” |
AIX | dpasswd -f <file> -U <username>, create encrypted password fro NIM |
AIX | chdev -l inet0 -a “<route type>,-hopcount,1,-netmask,<subnet mask>,<destination>,<gateway>” define persistent routes |
AIX | lsattr -El inet0, list persistent routes |
AIX | static routes can be added in /etc/rc.net |
AIX | nim -o cust -a lpp_source=<LPP_SOURCE> -a filesets='<rpmname>’ -a accept_licenses=yes -a show_progress=yes <Machinename>, install rpms via NIM |
SLR | cfgadm -al | grep -i fibre, location of Solaris HBA adapters |
UNIX | ps -ef | grep “[s]tring]”, to find a string without displaying the grep process |
AIX | procfiles -n <PID>, to list files used by a process |
AIX | nim -o cust -a lpp_source=<lpp_source> -a filesets=<fix_package_name> <machine> |
AIX | nim -o lslpp -a lslpp_flags=e <machine> |
AIX | installp -Or <fileset>, if ‘lppchk -v’ outputs that a fileset (usr: COMMITTED, root: not installed) |
SP | q san, TSM query of SAN devices |
AIX | /etc/security/roles, to modify RBAC roles. |
AIX | chrole auth_mode=NONE <role_name>, for no password prompt, /var/adm/rolelog records swrole usage. |
SP | TSM SQL sort, order by <column number> asc or order by <column number> desc |
SLR | cfgadm -v -l, cfgadm -c unconfigure <device path>, cfgadm -c configure <device path>, These are the steps to configure and reconfigure a Solaris device. |
SP | su – db2<sid>, /usr/tivoli/tsm/tdp_r3/db264/backom -e /db2/<SID>/tdp_r3/init<SID>.utl -c password , Set TDP R3 node passwords |
SP | su – db2<sid>, /usr/tivoli/tsm/tdp_r3/db264/backom -e /db2/<SID>/tdp_r3/init<SID>.utl -c q_db, query TDP R3 backups |
AIX | ctrmc and IBM.ServiceRM subsystems to work after AIX 7.1 upgrade, rsct.basic.rte must be installed. |
AIX | lsrsrc IBM.MCP, to retrieve HMC connectivity information in AIX 7.1 |
UNIX | /<exported directory> -anon=0,sec=sys,ro, set anon id to 0 to allow root access to NFS exports |
AIX | fsdb /<filesystem>, inode <number>, convert the di_otime.tj_sec to Decimal and the will give you the Unix time of the file creation. |
UNIX | ./vastool -u <AD username> passwd -rk /etc/opt/quest/vas/host.keytab host/, updates computer credentials in local keytab. Resolves IPC issues. |
UNIX | gcc <source.c> -o <compiled_output>, compile gcc program |
AIX | /usr/lib/security/mkuser.default file, defaults for creating AIX users |
AIX | chdev -U, change device attributes while it is in an Available state. |
AIX | lsmpio, list path information. |
UNIX | sed ‘s/'”VALUE=’OLD'”‘/'”VALUE=’NEW'”‘/g’, example of text replacement where special characters are used as part of the string. |
UNIX | TMP=”DB_DIR='”‘TMP'”‘”, encapsulating single quotes in variables. |
STG | lspcmcfg, SDDPCM command path information. |
AIX | installp -l -d <path to fileset>, fileset file information |
AIX | emgr -P, filesets locked by efixes |
AIX | multibos -Xc -b <fileset or fix bundle> -l <fileset or fix location>, install efixes in a multibos environment. |
AIX | create /var/tmp directory, if vi doesn’t work |
IBMi | dspfmwsts, systemi display firmware status |
IBMi | INZSYS, post IBMi OS upgrade. Especially if it doesn’t IPL from side B |
AIX | emgr -l -L <ifix_label> -v3, intermin fix information |
AIX | mklv -t jfs2 -y <lv_name> -e ‘x’ <vg_name> <PP>, create logical volume with maximum inter-policy across PVs |
AIX | chlv -e x <lv_name>, to set the inter-policy across PVs |
AIX | reorgvg <vg_name>, to reorganize the volume to the new logival volume policy |
SP | q auditocc pool=primary, TSM q auditocc primary or copy pools. |
AIX | monhmc -r <resource type> 1 -n 1, HMC monitoring tool |
SP | q backup ‘\\<servername>\<drive>\’ to query UNC paths from windows TSM clients |
UNIX | lspv | awk ‘{print $1,$2}’ | while read col1 col2 (Then do loop using $col1 and col $col2), for having variables with multiple columns. |
EXCH | Get-MailboxDatabase -Status | ft name,last* -auto , MS exchange backup listing |
UNIX | nohup -p, to nohup an existing process |
AIX | lspath -E -l <hdisk> -p <path> , show path priority |
SP | Program Files\Tivoli\TSM\console\tsmdlst.exe, List Windows tape and library devices |
LIN | multipath -ll -d, linux multipath command |
LIN | multipath -k, validate configuration. |
STG | fabricshow, brocade show switch domain id |
UNIX | du -sxh ./*/, List subdirectory sizes in the current directory |
LIN | mpathconf –enable –with_multipathd y, enable Linux multipath |
MS | select-string -pattern “<string>”, powershell find string |
UNIX | echo Please type something: (newline) read $variable, ksh input into a variable. |
LIN | echo “- – -” > /sys/class/scsi_host/<host>/scan, scan for new scsi devices on a scsi bus. |
LIN | echo “1” > /sys/class/scsi_device/<device Number>/device/rescan, on both multipath devices when you resize a disk. |
EXCH | New-MailboxDatabase -Recovery -Name <name> -Server <servername> -EdbFilePath <path\file.edb> -logFolderPath <path> Create exchange Recovery Database. |
SP | /usr/tivoli/tsm/client/api/bin64/dsm.sys, TDPr3 backint config. |
SP | backfm -p /oracle/<SID>/102_64/dbs/init<SID>.utl , get TDPr3 backup information |
AIX | chdev -l <hdisk> -a pv=clear, clear disk pvid. (recreatevg must be used to import the volume group) |
AIX | chsysstate -r lpar -m <MACHINE> -o shutdown –immed –restart -n <LPARNAME> |
AIX | lssyscfg -r lpar -m <MACHINE> –filter lpar_names=”<lpar>”, to see details of an LPAR |
STG | nsshow, in brocade will list WWPNS |
AIX | svmon -P -O sortseg=pgsp, sort processes by virtual memory usage. |
UNIX | powermt display, EMC powerpath display |
UNIX | powervt xcrypt -info -dev all, EMC powerpath display encryption. |
LIN | iptables -I INPUT -p udp -m udp –dport <port> -j ACCEPT, IP tables incoming rule for tcp/udp port |
LIN | iptables-save > /etc/sysconfig/iptables, IP tables commit |
AIX | errlogger <text>,generate an AIX error log. |
AIX | nimquery -a hmc=<hmcname> -p, to test HMC NIM object. |
AIX | nimquery -a cec=<cecname> -p, to test cec NIM object. |
UNIX | sort -n -k<n>, select sort field. |
DB | /etc/oratab, oracle database versions |
AIX | Power open firmware, option 8, ioinfo, FCINFO to show WWPN’s of LPAR adapters. |
STG | switchshow, shows all connected WWPN’s of every switch port. Brocade |
STG | cfcgclear, cfgsave. Clear brocade switch configuration |
STG | configure, change brocade switch configuration. E.g. domain ID |
STG | configupload, used to backup brocade configuration. |
STG | (Brocade zone/alias command “zone/alias”, “value; value”) Brocade zonecreate or alicreate command structure |
STG | Each node of every io group of in storwize cluster has to be zoned to the external storage, for storwize storage virtualization |
STG | At least two ports of every node in the storwize cluster needs to be zoned to the external storage, for storwize storage virtualization. (Not enough redundancy errors will appear in the event log) |
SCALE | Discover each linux multiplath host bus one at a time, using echo “- – -” > /sys/class/scsi_host/<host>/scan, when using scsi3 reserved disks for spectrum scale. |
PPC | ppc64_cpu –smt=on and ppc64_cpu –smt=off, toggle Linux Power SMT on or off and lscpu will validate |
AUTO | AIX puppet client installation requires a .rpmmacros file created with “%_tmppath /tmp” |
CLD | powervc-config general ifconfig –set –interface <interface_number>, to change powervc network configuration. |
MS | Computer Configuration /Windows Settings / Security Setting /Network List Manager Policies, Win2012 change network type |
LIN | Make a change to /etc/lvm/lvm.conf and has fixed the RH 7.2 duplicate PV issue. |
LIN | setenforce 0, to set selinux to permissive mode. |
SCALE | wbinfo -u, Spectrum Scale linux winbind user information |
SCALE | Spectrum Scale mmuserauth information, installed the Windows 2012 R2 NIS and password sync. The USER_NAME AD user (nas) had UNIX attributes on with a UID (10003) and GID (10001) within the UNIXMAP_DOMAINS range. Set the Primary group in Windows Users Membership to nas-users (10001) |
SCALE | mmcrfs <local_filesystem> -F <nsdfile> -B 64k, create local filesystem on local disk for Spectrum Scale AFM cache system E.g. mmcrfs afm1 -F disks -B 64k |
SCALE | mmcrfileset <local_filesystem_device> <fileset_name> -p afmTarget=<homeserver:nfsexportpath> –inode-space=new -p afmMode=single-writer, create AFM fileset on cache system. E.g. mmcrfileset /dev/afm1 cache -p afmTarget=gpfs2:/gpfs/dfs1/nas –inode-space=new -p afmMode=single-writer |
SCALE | mmlinkfileset <local_filesystem_device> <fileset> -J <newmountpoint_withinTheLocalfilesystemDevice>, Link new filesystem to new local mount point within the new device. E.g mmlinkfileset /dev/afm1 cache -J /gpfs/afm1/nas |
SCALE | mmchconfig cesSharedRoot=<newmountpoint_withinTheLocalfilesystemDevice>, Have the protocols (SMB or NFS) have this a root directory. E.g. mmchconfig cesSharedRoot=/gpfs/afm1/nas |
CLD | Add linux user to powervc filtergroup, usermod -a -G powervc-filter <user> |
CLD | Setup powervc openstack environment, source /opt/ibm/powervc/powervcrc, export OS_USERNAME=root, export OS_PASSWORD=<password> |
CLD | openstack project create –description “Project description” <project name> |
CLD | Add linux user to default ibm-default powervc project and define role, openstack role add –project ibm-default –user <user> <role> |
CLD | openstack role assignment list –names, list powervc users and their linked projects |
CLD | To set or unset powervc policy, export the OS_PROJECT_NAME variable. E.g. export OS_PROJECT_NAME=Linux |
CLD | powervc-cloud-config policy-list, to list powervc policy settings. |
CLD | powervc-cloud-config -p ibm-default set-policy default_expiration_days <numerical value>, set powervc VM expiration policy |
CLD | powervc-cloud-config -p ibm-default set-policy deploy_approval_limit -1, set powervc approval policy to no approval |
SCALE | mmchdisk <filesystem_device> change -F <nsd_stanza_file>, Spectrum Scale change nsd to dataOnly or metadataOnly |
SCALE | mmrestripefs <filesystem_device> -r, Spectrum Scale redistribute nsd data and metadata |
SCALE | dsmmigfs add <filesystem>, adds filesystem to HSM |
SCALE | dsmmigfs q -d, querys Spectrum Scale space management |
SCALE | Change Spectrum Protect space management node management class attributes SPACEMGTECHNIQUE=selective, MIGREQUIRESBKUP=yes, MIGDESTINATION=<storagepool> |
SCALE | /usr/lpp/mmfs/samples/ilm/mmpolicyRules-hsm.sample, for Spectrum Scale and Space Management policy script. |
AIX | mkcd -L -S -I <cd_image_directory> -m <mksysb_file>, create AIX mksysb file into bootable iso image. |
STG | Brocade SAN 16Gbps ports should be set to 32 via portcfgfportbuffers for NPIV VIOS |
DB | db2ilist, List db2 instances; db2idrop <instance> |
DB | db2_deinstall -a, to uninstall DB2 |
AIX | /usr/sbin/rsct/bin/lsnodeid, list AIX node id. |
AIX | PowerSC copy /etc/security/powersc/uiServer/endpointTruststore.jks to /etc/security/powersc/uiAgent/endpointTruststore.jks on every endpoint |
LIN | blockdev –getbsz <partition>, linux block size |
LIN | subscription-manager list –available, Red hat available subscriptions |
LIN | subscription-manager list –consumed, Red hat subscriptions available |
LIN | subscription-manager subscribe –pool=<pool_id> |
LIN | engine-iso-uploader –iso-domain=ISO_DOMAIN upload <iso_filename>, red hat virtualization manager iso upload |
AIX | lsnim -POt <nim resource_type> |
LEN | Must use vlan ID for VMWare PXE deployments |
LIN | Linux disk rescan tool, yum install sg3_utils.x86_64 and rescan-scsi-bus.sh |
SCALE | /usr/lpp/mmfs/4.2.3.0/installer/spectrumscale setup -s <admin node IP address>, setup admin node |
SCALE | /usr/lpp/mmfs/4.2.3.0/installer/spectrumscale config populate –node <admin node>, create /usr/lpp/mmfs/4.2.3.0/installer/configuration/clusterdefinition.txt |
SCALE | /usr/lpp/mmfs/4.2.3.0/installer/spectrumscale node add -q -a -m -n -p -g <new node>, create new node definition for /usr/lpp/mmfs/4.2.3.0/installer/configuration/clusterdefinition.txt |
SCALE | /usr/lpp/mmfs/4.2.3.0/installer/spectrumscale nsd servers add <nsd disk> -s <new node> |
SCALE | Install gpfs.license.std, to install spectrum scale via the spectrumscale toolkit. |
SCALE | /usr/lpp/mmfs/4.2.3.0/installer/spectrumscale install, to use the spectrum scale toolkit |
SCALE | install sssd ypbind openldap-clients rpms for spectrum scale protocols |
SCALE | /usr/lpp/mmfs/4.2.3.0/installer/spectrumscale deploy, to install spectrum scale protocols |
SCALE | ctdb status, NAS cluster status |
SCALE | smbstatus, samba connection status |
SCALE | mmces address add –ces-ip <IP address>, add additional IP addresses to the cluster |
SCALE | mmhealth node show, show spectrum scale node issues |
SCALE | mmces address add –ces-ip <IP address>, add additional IP addresses to the cluster |
SCALE | mmces address policy even-coverage, mmces address move –rebalance, these commands will balance multiple IP addresses across the cluster |
SCALE | mmperfmon config, configures the /opt/IBM/zimon/ZIMonSensors.cfg |
SCALE | mmcessmblsconfig, list samba configuration |
LIN | Linux winbind lookups, add “winbind” to the shadow,group and passwd sections of the /etc/nsswitch.conf file |
LIN | Linux winbind authentication, authconfig –enablewinbindauth –update |
LIN | mount -t cifs //<IP address>/<share>/ /<local_path> -o username=<user>,domain=<UPPER CASE DOMAIN>,vers=3\.0,uid=<AD_uidnumber>,gid=<AD_gidnumber> , For Spectrum Scale cifs linux clients |
STG | chiogrp -feature raid -size 80 io_grp0, increase storwize raid memory if additional mdisks cannot be created. |
AIX | cfgmgr -i <device>, this is used when a device is stating it needs a fileset. E.g. device.fcp.changer |
SCALE | dsmmigfs enablefailover, on all Spectrum Scale nodes in a cluster. |
SP | dsmc set password -type=vm <virtualcenter_fqdn> <“vcenteruser_in_quotes”> <“vcenterpassword_in_quotes”> -optfile=<datamover_optfile> -asnode=<proxytarget>, Spectrum Protect VE post installation. Note double quotes around vcenter user and password |
SCALE | /usr/lpp/mmfs/bin/net ads lookup -S <domain controller>, Spectrum Scale net ads lookup |
SCALE | mmdiag –config, show spectrum scale configuration options |
SCALE | mmchange config <configuration_option>=value, change Spectrum Scale configuration. |
STG | zoneobjectcopy “<configuration_name>”,”<newconfiguration_name>”, backup brocade SAN zoning configuration. |
UNIX | awk ‘{print substr($0, index($0,$5)) }’ < filename, awk to from row five to last row |
UNIX | $IFS=’\n’, must be used in for loops in shell scripts where the data has spaces |
UNIX | rsync -dirs –existing –ignore-existing –delete -e ssh /<source directory>/ root@ci-dr-sp-s:/<target directory>/, delete target directories only using rsync. |
SCALE | mmlsnodeclass –all, lists spectrum scale node classes |
SCALE | mmlsmgr, list spectrum scale manager |
LIN | flock -n </directory/lockfile> <script>, linux tool to stop duplicate tasks running in crontab. |
LIN | <input command> | parallel –will-cite -j <number of jobs> <command or script>. Linux parallel binary from the fedora epel-release repository to run multiple processes for tasks like rsync. |
UNIX | rsync can use {} as input, E.g cat list.txt | rsync -av {} user@server:/directory/ |
LIN | lsscsi -LH –transport, Linux Fiber channel adapter information |
AIX | AIX NIM “if1″ interface attributes modification example (<NIM_network hostname MAC_address>) /usr/lpp/bos.sysmgt/nim/methods/m_chattr -a if1=”ent-Network17 cyclone E41F134FB342” master |
AIX | nim_master_recover -i <interface_name> -S, to recover NIM master “if1” interface |
AIX | nfso -po portcheck=0, to fix the 0611 Nim install issue. |
AIX | Discover non IBM tape library devices on AIX, smit devices -> Tivoli Storage Manager Devices |
STG | V7000 IP replication, configure Ethernet Ports with dedicated IP addresses and enable “Remote Copy” only. Do not share remote copy and management ethernet ports. |
AUTO | ansible-doc -l, list ansible modules |
SCALE | When mmuserauth is used on a Spectrum Scale node, copy /etc/krb5.keytab to the other nodes to avoid SMB issues |
SCALE | To solve spectrum scale client connectivity issues between clustered nodes, add both the nodes and IP addresses into CES groups. |
SCALE | Spectrum Scale samba requires a fully qualified domain name for the Netbios name in /etc/hosts, also prefers to have the first entry. |
SCALE | /opt/tivoli/tsm/client/hsm/multiserver/bin/dsmreconcileGPFS.pl </spectrum_scale_filesystem>, space management reconciliation. |
SCALE | mmadquery list uid –user <username> –domain <domain fqdn>, Spectrum scale list all uids |
SCALE | mmcheckquota -a, schedule to update quota report information |
GIT | git clone -v https://github.com/<username>/<repo>.git <local_directory>, clone a github repository for local git use. |
GIT | mkdir ~/git-shell-commands, for git shell and commands |
GIT | git config user.email <email_address>, required by atom editor for git synchronization |
GIT | git config user.name <github username>, required by atom editor for git synchronization |
AUTO | ansible-playbooks –list-tasks <playbook_name>, to list and test all tasks in the playbook |
AUTO | ansible-playbooks <playbook_name> –extra-vars “var1=<value> var2=<value>”, have variables run in the command |
AUTO | Change ownership for Satellite dhcp provisioning, chown -R root:foreman-proxy /etc/dhcp |
AUTO | satellite-installer –scenario satellite –foreman-proxy-dhcp true –foreman-proxy-dhcp-interface <interface_name> –foreman-proxy-dhcp-range “<start_ip> <end_ip>” –foreman-proxy-dhcp-gateway <gateway_ip> –foreman-proxy-dhcp-nameservers <dns_ip>, manually enable satellite DHCP for PXE deployment. E.g. satellite-installer –scenario satellite –foreman-proxy-dhcp true –foreman-proxy-dhcp-interface eth0 –foreman-proxy-dhcp-range “192.168.0.5 192.168.0.90” –foreman-proxy-dhcp-gateway 192.168.0.254 –foreman-proxy-dhcp-nameservers 192.168.0.200 |
AUTO | When using a Satellite VMWare “<Datacenter/template_name”>, you must create a custom user provisioning template and make sure that the VM being used for the template will try and boot from PXE first (Go into BIOS and change boot order) then clone VM to template |
AUTO | If having puppet “Could not retrieve catalog” errors on Satellite 6 server, remove from satellite server from any host groups |
AUTO | awk ‘/^ *admin_password:/ { print $2 }’ > /etc/foreman-installer/scenarios.d/satellite-answers.yaml, to retrieve original satellite admin password |
AUTO | The Satellite hammer credentials are now in ~/.hammer/cli.modules.d/foreman.yml. Also the initial password was placed here. |
AUTO | For successful VMWare provisioning, only have one “Activation Key” with no subscriptions. A provisioned VM should automatically report to subscribed physical host. |
AUTO | If having any satellite puppet agent openscap issues, do not add any “openscap” puppet classes to your “host group”. Especially if no openscap policies have been defined |
LIN | reposync –repoid <Repo_name> –download_path=<directory> -m –download-metadata, download contents of remote repository |
LIN | wget -r -l 1 -N -e robots=off –no-directories -P <local_download_directory> -R index.html* http://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/RPMS/ppc-7.1/repodata/, download yum repository metadata if createrepo is not available. |
LIN | Use “use_proxy = on” and populate “http_proxy = http://<server>:<port>” in the /etc/wgetrc file to have wget use a proxy server |
LIN | apachectl configtest, to test the httpd.conf settings |
LIN | “Allowoverrides All” in httpd.conf, allows the use of .htaccess files in apache. |
SCALE | Use (MISC_ATTRIBUTES LIKE ‘%M%’ AND MISC_ATTRIBUTES NOT LIKE ‘%V%’) spectrum scale policy syntax for HSM pre-migrated files. Pre-migrated files still exist in the Spectrum Scale filesystem |
SCALE | Use (MISC_ATTRIBUTES LIKE ‘%V%’) spectrum scale policy syntax for HSM migrated files, Migrated files are only stubs in the Spectrum Scale filesystem |
SCALE | mmattr -d </path/file_name>, will display Spectrum Scale attributes of a file |
LIN | rename .conf files in /etc/httpd/conf.d with a suffix other than .conf to remove any conflicting apache configuration with any other webservice. E.g. ssl.conf to ssl.conf.notused |
DOCKER | docker container inspect <container>, docker container configuration details |
DOCKER | docker image inspect <image>, docker image configuration details |
DOCKER | docker container ls -a, list all docker containers |
DOCKER | docker run –name portainer -d -p 9000:9000 -v /var/run/docker.sock:/var/run/docker.sock -v portainer_data:/data portainer/portainer, create portainer container and persistent data volume and then “http://<hostname>:9000” for docker GUI management |
DOCKER | docker container start <container>, start docker container |
DOCKER | create a directory and then create a docker-compose.yaml in the directory to create and manage containers via docker-compose. |
DOCKER | In the docker-compose.yaml directory, “docker-compose up -d” to create or start container in the background and “docker-compose down” to stop the container |
DOCKER | docker exec -it <container_name> /bin/bash, run commands in a docker container. use “exit” command to exit the container session. |
DOCKER | docker run –name registry -d -p 5000:5000 -v registry_data:/var/lib/registry registry:2, install local docker registry |
DOCKER | pip install docker-py, to allow docker-compose to use local registry images |
MSSQL | Move-ClusterResource -Name “Cluster Name” -Group “Cluster Group”, if the Cluster Name is accidentaly moved into a role in the Windows Failover cluster Manager |
LIN | Apache 2.4.25 onwards can have issues with reverse proxy traffic, the HttpProtocolOptions directive affects this behaviour |
DOCKER | docker network create ansible –subnet 192.168.20.0/29 –gateway 192.168.20.1, create a custom docker bridge network using a specific subnet. E.g. ansible. The example subnet and gateway used are non routable to the docker host. |
LIN | Disable IPv6 on Centos7, have “ipv6.disable=1” as the first argument in the GRUB_CMDLINE_LINUX line in /etc/default/grub. Then “grub2-mkconfig -o /boot/grub2/grub.cfg” to recreate boot configuration |
VMWARE | vmkfstools -J getuuid “/vmfs/volumes/<datastore_name>/<disk_file>.vmdk”, to determine disk ID |
AIX | lshwres -m <server name> -r virtualio –rsubtype eth –level lpar –filter lpar_ids=<LPAR ID>, list virtual LAN slots on IVM (VIOS) server |
AIX | chhwres -m <server name> -p <VIOS LPAR name> -o a -r virtualio –rsubtype eth -s <slot number> -a “ieee_virtual_eth=1,port_vlan_id=20,\”addl_vlan_ids=25,30\”,is_trunk=1,trunk_priority=1″ -d 5, add virtual LAN adapter to IVM (VIOS) server with PVID 20 and VLAN’s 25 and 30 |
MS | Set-ClusterQuorum -NodeAndFileShareMajority “\\<Server>\<share>”, Create Windows file share witness for MS Cluster. |
MS | Parse spaces in Powershell environment example. ‘cp \\server\Department` Folder\automation\*.* C:\temp\’ |
MS | setspn -L <domain>\<user> or <computer>, to list existing SPN associations made via the setspn command |
MS | Add line “registry=http://registry.npmjs.org/” in %USERPROFILE%\.atom\.apmrc for Windows Atom to install packages and updates successfully using cntlm local proxy service |
AIX | netstat -Aan, rmsock <pcb addr> tcpcb, to find what process id is using a socket on AIX |
LIN | ls -ld /proc/<pid number>, to find the start date and time of a process that had started before the current date |
LIN | pvresize, to resize a scsi device that has been allocated as a physical volume in LVM |
AIX | lvmo -v <vgname> -a, to display blocked IO count for a volume group and can compare against the global value |
AIX | lvmo –v <vgname> -o pv_pbuf_count=2048, if the blocked IO count is high and has increased |
MS | quser; mstsc /shadow:<id> /control, quser will list users and RDP session ID’s and then use the mstsc command to shadow or control a RDP session |
MS | Get-ADGroup -Filter {Name -like “something*”} | select Name, PS example of filtering of a feild using a wildcard value and then selecting a feild. |
UNIX | awk ‘$1 !~ /[0-9]/’, awk listing 1st column with no numbers. |
EXCH | Get-MailboxDatabase -Status | select Name,DatabaseSize ,Get Exchange Mail Database sizes |
AUTO | http://jsonviewer.stack.hu/, is useful to for displaying unformatted JSON data like Ansible output |
VMWARE | esxcli software vib install -d /vmfs/volumes/<datastore>/<offline_bundle>.zip, to upgrade VMWare ESXi to an update release. |
DOCKER | docker stack deploy -c docker-compose.yml wordpress, start a docker stack from the docker-compose.yml file and call it wordpress (from Manager node) |
DOCKER | docker stack ls, to list running docker stacks (from Manager node) |
DOCKER | docker stack rm <stack_name>, to stop a docker swarm stack (from Manager node) |
DOCKER | docker services ls, to view running docker containers running as part of a stack (from Manager node) |
DOCKER | docker node ls, to view nodes in a docker swarm (from Manager node) |
LIN | RedirectMatch 301 ^/ https://www.example.com/webpage, apache vhost redirects any URL to “https://www.example.com/webpage” |
LIN | vdo growLogical –name=<vdo_volume_name> –vdoLogicalSize=200G, to increase the logical size of a vdo volume. |
LIN | xfs_growfs /<mount_point>, to resize an xfs volume. This also needs to done when the vdoLogicalSize has been increased to an underlying vdo volume. |
AIX | lsnim -Fl <object_name>, this displays detailed information about a nim object. E.g. last error on a NIM machine. |
AIX | alt_rootvg_op -X old_rootvg, cleans up the old_rootvg volume group |
MS | Boot from WinPE media. Then diskpart, list volume, select volume <n>, assign letter=S to assign the Windows System volume a letter. From command line bcdboot C:\Windows /s S: to copy a boot environment to the system volume and reboot. |
AIX | smit mkvirprt, to create device printers, e.g. Lexmark |
AIX | dump -H -X32_64 </path/binary>, see AIX binary headers with libary information |
AIX | ar -tv </path/library.a>, list objects in library archive file |
VMWARE | esxcfg-vmknic -l, List vmkernel IP Address |
VMWARE | esxcli network ip neighbor list, Arp table list |
VMWARE | esxcli network nic list, Physical NIC list |
VMWARE | esxcli network ip interface list, list vmkernel network details |
VMWARE | esxcli network nic get -n <device>, vmnic device details |
VMWARE | esxcli network nic up -n vmnic<n>, Bring down physical device |
VMWARE | esxcli network nic down -n vmnic<n>, Bring up physical device |
VMWARE | esxcli software vib list | more, list drivers and software |
VMWARE | esxtop; then n, for network statistics |
VMWARE | vmkping -I vmk<device> <IP address>, vmkernel ping |
OS10 | configure terminal; interface ethernet <device>; no switchport trunk allowed vlan <vlan ids>, remove VLANs from an interface |
OS10 | configure terminal; interface range ethernet <devices>; switchport trunk allowed vlan <vlan ids>; add VLANs from to interfaces |
OS10 | system “sudo -i passwd linuxadmin”, change linuxadmin switch user password |
OS10 | terminal length 24, no pause output |
OS10 | terminal length 0, pause output |
OS10 | show inventory, switch information. |
OS10 | show inventory media, show physical switch port tranceivers, cables etc. |
OS10 | write memory to save configuration |
OS10 | show diff running-configuration startup-configuration, compare running to startup configuration. |
MS | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0 -> Multi-String Value -> BackConnectionHostNames, value data <powerbi hostname used in URL>, This is to be used for PowerBI NTLM authentication |
LIN | openssl s_client -connect <servername>:443 -tls1_1, establish TLS version support for a particular server |
LIN | nmap –script ssl-enum-ciphers -p 443 <servername>, list supported TLS versions for a particular server |
AUTO | ansible-vault encrypt /etc/ansible/group-vars/servers.yml, ansible-vault edit /etc/ansible/group-vars/servers.yml and ansible-vault view /etc/ansible/group-vars/servers.yml. Ansible vault examples |
AUTO | ansible servers -m win_ping –ask-vault-pass. Example to invoke Ansible vault, “servers” are the ansible group |
LIN | loginctl, systemd who command |
AIX | fuser -dV <filesystem>, will show inodes from defunct processes and the process ids |
MS | Enter-PSSession -ComputerName <servername>, for a remote Powershell session |
MS | Test-NetConnection -ComputerName <servername> -Port <port>, to test network connections. |
VMWARE | service-control command VCSA 6.5 onward replaces VCSA 6 service command |
VMWARE | service-control –start <servicename>, start a vCenter service |
VMWARE | service-control –status, will show status of all vCenter services |
AIX | odmget -q name=<lvname> CuAt > /tmp/<lvname>.out, odmget -q name=<lvname> CuDv > /tmp/<lvname>_dv.out, odmdelete -o CuAt -q name=<lvname>, odmdelete -o CuDv -q name=<lvname>, synclvodm <vgname>, removing an old logical volume |
AIX | smit nim_alt_clone, forks of into a background process. On NIM server lsnim -l <client_machine> to monitor status. On NIM client monitor the /var/adm/ras/nim.alt_disk_install log for installation information. |
DOCKER | cd <Dockerfile_directory>, docker build -t <repository>/<name>:<tag> . Build docker image |
DOCKER | docker run -d -p <listen_port>:<port> –name <repository>/<name>:<tag> |
LIN | yum –showduplicates list <packagename>, list all available versions of a particular yum package |
SCALE | mmnetverify ping -N all, test Spectrum Scale connectivity to all nodes in a cluster |
MS | dism /online /get-packages /format:table, list windows packages and updates |
LIN | ad_enable_gc = False in /etc/sssd/sssd.conf, AD groups were working after this setting |
LIN | needs-restarting -r , for RH7 or yum needs-restarting, RH8 (can be installed via yum-utils package) |
LIN | nmap -v -sn -n 192.168.1.0/24 -oG – | awk ‘/Status: Down/{print $2}’ , port scan subnet for free IP addresses |
LIN | grubby –set-default=/boot/vmlinuz-4.18.0-348.20.1.el8_5.x86_64 , RH8 set default kernel |
LIN | grubby –default-kernel , RH* list default kernel |
LIN | yum list extras –disablerepo=”*” –enablerepo=<repository> , List addtional packages installed outside of a repository |
LIN | repoquery -q –whatrequires <package> , List packages dependant of a particular package |
LIN | yum deplist<package> , list the dependencies of a particular package. |
LIN | cat /proc/meminfo , reference Hugetlb for Oracle Database memory usage |
LIN | yum swap libvirt-python python2-libvirt , this will replace libvirt-python with python2-libvirt |
SCALE | mmchdisk <filesystem> start -d <diskname> , start a NSD disk that is in a down state |
AUTO | pid-stat -q –ssl-certificate=/etc/pki/pulp/qpid/client.crt -b amqps://localhost:5671 resource_manager , RH Satellite 6.n Pulp queue jobs |
AUTO | for i in pulp_resource_manager pulp_workers pulp_celerybeat; do service $i restart; done , restart RH Satellite 6.n Pulp services when Content view update is stuck |
AUTO | foreman-rake katello:reindex, foreman-maintain service restart , Restart RH Satellite 6.n service |
AUTO | systemctl restart virt-who.service , on RH Satellite server to resolve issues with virtual guest subscriptions. |
MS | dir env: , Show PowerShell variables |
AWS | $Env:AWS_CA_BUNDLE=”<DRIVE:>\<PATH>\CAFILE” , AWS SSO Variable to allow AWS CLI access through proxy servers. |
SCALE | mmgetstate -Las , Spectrum Scale cluster and quorum status |